问题解决zipimport.ZipImportError: can‘t decompress data; zlib not availabl

前面写过一篇简单方法安装pip的文章:https://www.pythontab.com/html/2015/pythonhexinbiancheng_1012/963.html

但是在某些环境下执行安装的时候会报错,导致安装不成功, 今天就说一下我遇到的一个问题。

报错

[www@pythontab.com ~]$ https://bootstrap.pypa.io/get-pip.py
[www@pythontab.com ~]$ sudo python get-pip.py

报错提示“zipimport.ZipImportError: can‘t decompress data; zlib not available”

看起来是因为缺少响应的zlib库,需要先安装再执行。

问题解决

[www@pythontab.com ~]$ sudo yum install zlib

安装完成后发现还是会报错, Google搜索发现,需要安装zlib-dev

所以我们再次安装zlib库

[www@pythontab.com ~]$ sudo yum install zlib*

这次安装完成应该是OK了, 可以结果令人失望, 依然报相同的错误。

但是明明我们已经安装了zlib库啊, 为什么还会报错呢?


查询资料发现需要重新编译安装python

在重新编译之前还需要在安装源文件中修改Modules/Setup.dist文件,将

#zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz

这行的注释去掉,变为:

zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz

然后在次编译安装(在Python的安装源文件目录执行如下命令)

[www@pythontab.com ~]$ make && make install

重新安装完成

执行:

[www@pythontab.com ~]$ sudo python get-pip.py

安装pip成功!


PythonTab微信公众号:

Python技术交流互助群 ( 请勿加多个群 ):

群1: 87464755

群2: 333646237

群3: 318130924

群4: 385100854

相关词搜索:zlib pip

上一篇:Python判断对象是否为文件对象(file object)的三种方法
下一篇: Python2 和 Python3 的区别及兼容技巧